How should I use the sqlite3 tool?(for linux)

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

How should I use the sqlite3 tool?(for linux)

算 子
After I download the tool,I cd to the path,then,I run "./sqlite3"

But It can't work,here are error msgs:

./sqlite3: error while loading shared libraries: libz.so.1: cannot open
shared object file: No such file or directory

So,What should I do for it?

_______________________________________________
sqlite-users mailing list
[hidden email]
http://mailinglists.sqlite.org/cgi-bin/mailman/listinfo/sqlite-users
Reply | Threaded
Open this post in threaded view
|

Re: How should I use the sqlite3 tool?(for linux)

算 子
My OS is Debian10 amd64,desktop is xfce4

_______________________________________________
sqlite-users mailing list
[hidden email]
http://mailinglists.sqlite.org/cgi-bin/mailman/listinfo/sqlite-users
Reply | Threaded
Open this post in threaded view
|

Re: How should I use the sqlite3 tool?(for linux)

Rowan Worth-2
This means you're missing a dependency - in this case zlib. It's hard to
believe you don't have zlib on your system at all; probably this is
happening because your system is amd64 but the sqlite binary you've
downloaded is x86. I'm not a debian user but this should get you going:

apt-get install zlib1g:i368

(alternately, you can download the sqlite source and compile your own
binary which will be amd64 compatible)
-Rowan

On Tue, 3 Mar 2020 at 16:42, suanzi <[hidden email]> wrote:

> My OS is Debian10 amd64,desktop is xfce4
>
> _______________________________________________
> sqlite-users mailing list
> [hidden email]
> http://mailinglists.sqlite.org/cgi-bin/mailman/listinfo/sqlite-users
>
_______________________________________________
sqlite-users mailing list
[hidden email]
http://mailinglists.sqlite.org/cgi-bin/mailman/listinfo/sqlite-users
Reply | Threaded
Open this post in threaded view
|

Re: How should I use the sqlite3 tool?(for linux)

算 子
Thank you,you let me know what happened.

About your answer,I try it,but it can't work,maybe because can't have
two zlib.

apt-get could not find zlib:i386.

And there have not sqlite3 tool for linux x64 in sqlite.org

Anyway,thank you,I plan download the sqlite source and compile.

_______________________________________________
sqlite-users mailing list
[hidden email]
http://mailinglists.sqlite.org/cgi-bin/mailman/listinfo/sqlite-users
Reply | Threaded
Open this post in threaded view
|

Re: How should I use the sqlite3 tool?(for linux)

nomad
On Tue Mar 03, 2020 at 05:12:17PM +0800, suanzi wrote:
> Thank you,you let me know what happened.
>
> About your answer,I try it,but it can't work,maybe because can't have two
> zlib.
>
> apt-get could not find zlib:i386.

Did you specifically try "zlib1g"? I don't think the "zlib" package exists.

        mark@b:~$ uname -a
        Linux b 4.19.0-8-amd64 #1 SMP Debian 4.19.98-1 (2020-01-26) x86_64
        GNU/Linux

        mark@b:~$ dpkg -S libz.so.1
        zlib1g:amd64: /lib/x86_64-linux-gnu/libz.so.1
        zlib1g:amd64: /lib/x86_64-linux-gnu/libz.so.1.2.11

--
Mark Lawrence
_______________________________________________
sqlite-users mailing list
[hidden email]
http://mailinglists.sqlite.org/cgi-bin/mailman/listinfo/sqlite-users