Impossible to open or create database phpsla.sqlite

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Impossible to open or create database phpsla.sqlite

Peter Reinhardt

Hi,
i am a user on following machine:
--------------------------------------------------------------------------
Machine hardware:   sun4u
OS version:         5.8
Processor type:     sparc
Hardware:           SUNW,Sun-Fire-880

The following components are installed on your system:


Sun Studio 10
        Sun Studio 10 C Compiler
        Sun Studio 10 C++ Compiler
        Sun Studio 10 Tools.h++ 7.1
        Sun Studio 10 C++ Standard 64-bit Class Library
        Sun Studio 10 Garbage Collector
        Sun Studio 10 Fortran 95
        Sun Studio 10 Debugging Tools (including dbx)
        Sun Studio 10 Debugger GUI
        Sun Studio 10 Performance Analyzer (including collect, ...)
        Sun Studio 10 X-Designer
        Sun Studio 10 VIM editor
        Sun Studio 10 XEmacs editor
        Sun Studio 10 Native Connector Tool
        Sun Studio 10 LockLint
        Sun Studio 10 Building Software (including dmake)
        Sun Studio 10 Documentation Set

version of "/opt/SUNWspro/bin/../prod/bin/../../bin/cc": Sun C 5.7 Patch
117836-03 2005/05/11
version of "/opt/SUNWspro/bin/../prod/bin/../../bin/CC": Sun C++ 5.7 Patch
117830-02 2005/03/30
version of "/opt/SUNWspro/bin/../prod/bin/../../bin/f90": Sun Fortran 95
8.1 Patch 117834-02 2005/03/30
version of "/opt/SUNWspro/bin/../prod/bin/../../bin/dbx": Sun Dbx Debugger
7.4 117844-02 2005/07/15
version of "/opt/SUNWspro/bin/../prod/bin/../../bin/analyzer": Sun
Performance Analyzer 7.4 2005/01/07
version of "/opt/SUNWspro/bin/../prod/bin/../../bin/dmake": Sun
Distributed Make 7.6 117838-01 2005/03/04
--------------------------------------------------------------------------
Now I have a problem. I work with the latest release of XAMPP for Solaris
and everything worked fine until this morning. Now I have the problem,
when I try to open or use the SQLite database, the following error-message
appears: "Impossible to open or create database phpsla.sqlite". I tried to
uninstall the complete XAMPP-package, but when reinstalling it, I got the
same problem again (even if it was installed in a different directory).
The "phpsla.sqlite" does exist and it is about 7kB big. It is the standard
that comes with the XAMPP-package. Can anyone help me with this problem? I
am not the administrator of this machine, so the apache and the mysql
servers run on different ports as the standards are set (8497 instead of
80, 84979 instead of 3306). I can access the mysql-configuration-site from
the internet, but i am not able to open the phpsqliteadmin-routine. Even
when I open sqlite by typing "sqlite phpsla.sqlite" and then trying to read
out of the database file with "read phpsla.sqlite", the same error raises.
So can you give me a hint, how to solve this problem?
Thanks in advance,

Peter