[OT] Updating sqlite in PHP windows

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

[OT] Updating sqlite in PHP windows

Eduardo

Hello and sorry for the light offtopic, but can't find useful answers.

Firstly, the decision of use windows server and php 5.6 (with wampserver) is
not mine, I must use them. As Unix developer windows is harsh to me.

Current PHP5.6.32 (26 Oct 2017) has sqlite 3.8 version, but I want to use JSON
and FTS5 extensions. Almost all answers I get on other sources are, "don't use
sqlite3, use this 'other cool technology (TM)' ". The only valid answer I found
is recompile PHP with last sqlite3 version, using VC11 compiler (others won't
work).

I tried to compile with VS2015 but the dll don't work with PHP5.6 (php5.6
doesn't detect/show sqlite3 in phpinfo). The dll works with other apps dynamic
linking to it.

cl sqlite3.c -O2 -DDSQLITE_ENABLE_FTS5 -DSQLITE_ENABLE_JSON1 -link -dll -out:sqlite3.dll

Does anyone have a modern sqlite3.dll for PHP 5.6 with JSON and FTS5 extensions
on? Is there any paraoficial safe site where I can download it?

Or better, a recipe that works to compile sqlite3 on php5.6.x?

Thanks

--
Eduardo <[hidden email]>
_______________________________________________
sqlite-users mailing list
[hidden email]
http://mailinglists.sqlite.org/cgi-bin/mailman/listinfo/sqlite-users
Reply | Threaded
Open this post in threaded view
|

Re: [OT] Updating sqlite in PHP windows

Simon Slavin-3


On 20 Nov 2017, at 11:06am, Eduardo <[hidden email]> wrote:

> Or better, a recipe that works to compile sqlite3 on php5.6.x?

This is the best-looking page I’ve found, but I have never tried it on Windows.

<https://stackoverflow.com/questions/948899/how-to-enable-sqlite3-for-php#949325>

Simon.
_______________________________________________
sqlite-users mailing list
[hidden email]
http://mailinglists.sqlite.org/cgi-bin/mailman/listinfo/sqlite-users
Reply | Threaded
Open this post in threaded view
|

Re: [OT] Updating sqlite in PHP windows

Eduardo
On Mon, 20 Nov 2017 14:33:53 +0000
Simon Slavin <[hidden email]> escribió:

> On 20 Nov 2017, at 11:06am, Eduardo <[hidden email]> wrote:
>
> > Or better, a recipe that works to compile sqlite3 on php5.6.x?
>
> This is the best-looking page I’ve found, but I have never tried it on Windows.
>
> <https://stackoverflow.com/questions/948899/how-to-enable-sqlite3-for-php#949325>

Thanks Simon. It seems that php 5.6 it's EOL and all updates (except security) are on 7.1 and 7.2 branchs.

See the answers I get from php staff, 7.2 will have 3.21 version plus FTS and JSON extensions on (If I understand correctly)

https://bugs.php.net/bug.php?id=75544

> Simon.


--
Eduardo <[hidden email]>
_______________________________________________
sqlite-users mailing list
[hidden email]
http://mailinglists.sqlite.org/cgi-bin/mailman/listinfo/sqlite-users
Reply | Threaded
Open this post in threaded view
|

Re: [OT] Updating sqlite in PHP windows

Simon Slavin-3


On 21 Nov 2017, at 10:30am, Eduardo <[hidden email]> wrote:

> Thanks Simon. It seems that php 5.6 it's EOL and all updates (except security) are on 7.1 and 7.2 branchs.
>
> See the answers I get from php staff, 7.2 will have 3.21 version plus FTS and JSON extensions on (If I understand correctly)

Oh good grief yes.  If you’re still using PHP 5 please upgrade to PHP 7 unless you have compatibility problems.  So many bugs fixed, so much better security.

Which version of SQLite you get with it depends on your source and platform, but you can cross that bridge when you come to it.

Simon.
_______________________________________________
sqlite-users mailing list
[hidden email]
http://mailinglists.sqlite.org/cgi-bin/mailman/listinfo/sqlite-users