PHP 4 and SQLite3

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

PHP 4 and SQLite3

rossati@libero.it
Hello
I must use SQLite functions of PHP 4, but it seems that these functions doesn't works with SQLite 3.

What can I do?

best regards

Giovanni Rossati


_______________________________________________
sqlite-users mailing list
[hidden email]
http://sqlite.org:8080/cgi-bin/mailman/listinfo/sqlite-users
Reply | Threaded
Open this post in threaded view
|

Re: PHP 4 and SQLite3

Kees Nuyt

Hi Giovanni,

On Wed, 12 Mar 2008 20:50:13 +0100, you wrote:

>Hello
>I must use SQLite functions of PHP 4, but it seems
>that these functions doesn't works with SQLite 3.

Indeed the sqlite_ functions in PHP 4 are SQLite 2
only.

>What can I do?

Use SQLite 2.
Or find out if there is a SQLite3 capable PDO_sqlite
for PHP4 (I doubt it, PHP4 practically reached end of
life).

>best regards
>
>Giovanni Rossati
--
  (  Kees Nuyt
  )
c[_]
_______________________________________________
sqlite-users mailing list
[hidden email]
http://sqlite.org:8080/cgi-bin/mailman/listinfo/sqlite-users
Reply | Threaded
Open this post in threaded view
|

Re: PHP 4 and SQLite3

Eugene Wee
In reply to this post by rossati@libero.it
Hi,

This may be something of a non-solution, but you should pressure your
host to upgrade to PHP 5 and provide the PDO extension from which you
can use SQLite 3.

Note that the PHP website (http://www.php.net/downloads.php) states:
"Support for PHP 4 has been discontinued since 2007-12-31. Please
consider upgrading to PHP 5.2."

Regards,
Eugene Wee

[hidden email] wrote:
> Hello
> I must use SQLite functions of PHP 4, but it seems that these functions doesn't works with SQLite 3.
>
> What can I do?
>
> best regards
>
> Giovanni Rossati
_______________________________________________
sqlite-users mailing list
[hidden email]
http://sqlite.org:8080/cgi-bin/mailman/listinfo/sqlite-users