codeblocks thing happens when using codeblocks to compile sqlite with geopoly

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

codeblocks thing happens when using codeblocks to compile sqlite with geopoly

Graham Hardman
Hi,

I have built versions of the commandline shell and the dll so as to get
access to the geopoly module. My builds were done firstly using the
mingW64 compiler (from the command prompt) on windows10, and then later
using codeblocks. For both builds I specified the same set of compile
time directives that included SQLITE_ENABLE_RTREE and
SQLITE_ENABLE_GEOPOLY. Both build sets appeared successful in that there
were no error codes returned, and I could successfully create a table
using geopoly, insert and manipulate the records.

With my files built from the command prompt I ran the pragma
compile_options and see that geopoly is listed as expected. With my
files as built from within codeblocks the same test has geopoly omitted,
yet as i said above the files respond to me issuing geopoly-related
instructions.

Can anyone make sense of this, and should i be worried?

Thanks,

Graham
_______________________________________________
sqlite-users mailing list
[hidden email]
http://mailinglists.sqlite.org/cgi-bin/mailman/listinfo/sqlite-users
Reply | Threaded
Open this post in threaded view
|

Re: codeblocks thing happens when using codeblocks to compile sqlite with geopoly

Richard Hipp-3
On 10/24/18, Graham Hardman <[hidden email]> wrote:
>
> With my files built from the command prompt I ran the pragma
> compile_options and see that geopoly is listed as expected.

Are you sure?  Can you double-check?  Because I just looked at the
source code and it appears I mistakenly omitted ENABLE_GEOPOLY from
the "PRAGMA compile_options" command.
--
D. Richard Hipp
[hidden email]
_______________________________________________
sqlite-users mailing list
[hidden email]
http://mailinglists.sqlite.org/cgi-bin/mailman/listinfo/sqlite-users