configure failure for aarch64

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

configure failure for aarch64

Beat Küng
Hi

I'm trying to build sqlite (the latest release 3.28.0) for an aarch64
build target and get the following error:

checking build system type...
./config.guess: unable to guess system type
This script, last modified 2007-07-22, has failed to recognize
the operating system you are using. It is advised that you
download the most up to date version of the config scripts from
 
http://savannah.gnu.org/cgi-bin/viewcvs/*checkout*/config/config/config.guess
and
 
http://savannah.gnu.org/cgi-bin/viewcvs/*checkout*/config/config/config.sub
If the version you run (./config.guess) is already up to date, please
send the following data and any information you think might be
pertinent to <[hidden email]> in order to provide the needed
information to handle your system.
config.guess timestamp = 2007-07-22
uname -m = aarch64
uname -r = 4.15.0-45-generic
uname -s = Linux
uname -v = #48~16.04.1 SMP Fri Feb 8 10:38:11 UTC 2019
/usr/bin/uname -p =
/bin/uname -X     =
hostinfo               =
/bin/universe          =
/usr/bin/arch -k       =
/bin/arch              =
/usr/bin/oslevel       =
/usr/convex/getsysinfo =
UNAME_MACHINE = aarch64
UNAME_RELEASE = 4.15.0-45-generic
UNAME_SYSTEM  = Linux
UNAME_VERSION = #48~16.04.1 SMP Fri Feb 8 10:38:11 UTC 2019


Just downloading the latest config.guess via
wget
'http://git.savannah.gnu.org/gitweb/?p=config.git;a=blob_plain;f=config.guess;hb=HEAD'
-O config.guess
solves the issue.

Can you update that file in the source tree?
Thanks
Beat
_______________________________________________
sqlite-users mailing list
[hidden email]
http://mailinglists.sqlite.org/cgi-bin/mailman/listinfo/sqlite-users
Reply | Threaded
Open this post in threaded view
|

Re: configure failure for aarch64

Dan Kennedy-4

On 7/6/62 20:17, Beat Küng wrote:

> Hi
>
> I'm trying to build sqlite (the latest release 3.28.0) for an aarch64
> build target and get the following error:
>
> checking build system type...
> ./config.guess: unable to guess system type
> This script, last modified 2007-07-22, has failed to recognize
> the operating system you are using. It is advised that you
> download the most up to date version of the config scripts from
>  
> http://savannah.gnu.org/cgi-bin/viewcvs/*checkout*/config/config/config.guess
> and
>  
> http://savannah.gnu.org/cgi-bin/viewcvs/*checkout*/config/config/config.sub
> If the version you run (./config.guess) is already up to date, please
> send the following data and any information you think might be
> pertinent to <[hidden email]> in order to provide the needed
> information to handle your system.
> config.guess timestamp = 2007-07-22
> uname -m = aarch64
> uname -r = 4.15.0-45-generic
> uname -s = Linux
> uname -v = #48~16.04.1 SMP Fri Feb 8 10:38:11 UTC 2019
> /usr/bin/uname -p =
> /bin/uname -X     =
> hostinfo               =
> /bin/universe          =
> /usr/bin/arch -k       =
> /bin/arch              =
> /usr/bin/oslevel       =
> /usr/convex/getsysinfo =
> UNAME_MACHINE = aarch64
> UNAME_RELEASE = 4.15.0-45-generic
> UNAME_SYSTEM  = Linux
> UNAME_VERSION = #48~16.04.1 SMP Fri Feb 8 10:38:11 UTC 2019
>
>
> Just downloading the latest config.guess via
> wget
> 'http://git.savannah.gnu.org/gitweb/?p=config.git;a=blob_plain;f=config.guess;hb=HEAD'
> -O config.guess
> solves the issue.
>
> Can you update that file in the source tree?

Now updated here:

   https://sqlite.org/src/info/be8438133f6cd87e


Dan.


_______________________________________________
sqlite-users mailing list
[hidden email]
http://mailinglists.sqlite.org/cgi-bin/mailman/listinfo/sqlite-users