glibc version issue

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

glibc version issue

Craig Jacobs
I am trying to use sqlite in an embedded linux application. Unfortunately,
the OS we are running on the system is a bit old and there is no great way
to update existing units. When I tried to load the sqlite library, it
complains about GLIBC_VERSION not matching. I haven't really gotten into
cross-compiling (I was kinda trying to stay out of it).

Does anyone have any suggestions or maybe even a precompiled x86 binary that
wants GLIBC 2.2?

I appreciate it!

-Craig

P.S.: I realize this may have been the wrong list on which to ask a question
about cross compiling. I apologize.
Reply | Threaded
Open this post in threaded view
|

Re: glibc version issue

G. Roderick Singleton
On Fri, 2005-10-14 at 09:22 -0600, Craig Jacobs wrote:

> I am trying to use sqlite in an embedded linux application. Unfortunately,
> the OS we are running on the system is a bit old and there is no great way
> to update existing units. When I tried to load the sqlite library, it
> complains about GLIBC_VERSION not matching. I haven't really gotten into
> cross-compiling (I was kinda trying to stay out of it).
>
> Does anyone have any suggestions or maybe even a precompiled x86 binary that
> wants GLIBC 2.2?
>
> I appreciate it!

Have a look at http://www.sqlite.org/cvstrac/wiki?p=HowToCompile for
building statically.

--
G. Roderick Singleton <[hidden email]>
PATH tech