system reboot with Qt 4.8.7 and '-system-sqlite' using libsqlite >= 3.21.0

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

system reboot with Qt 4.8.7 and '-system-sqlite' using libsqlite >= 3.21.0

Scherer, Thorsten
Hello everybody,

I'll try to describe the issue very brief and will add further info, if needed/requested.

    Prerequesties
        Qt 4.8.7 (upgrade is not an option)
        built with gcc-7.3.1 for an imx25 board
        linux kernel 4.17.19
        the need to use "attach" and "detach" inside transactions and therefor using "-
system-sqlite" with a newer version of libsqlite (greater than 3.21.0 released on 2017-10-
24)

    Description / observed behavior

The code that uses "attach" and "detach" inside transactions runs every 15min (copies data
from in-memory sqlite files to sqlite files on persistent storage). This is never reached,
since the system is restarted via watchdog every (roundabout) 10 minutes. In this time
the system collection various data from various I/O.

    Qt with built in sqlite (3.7.7.1) -> system works as expected
    Qt with '-system-sqlite' and libsqlite 3.7.7.1 -> system works as expected
    Qt with '-system-sqlite' and libsqlite 3.21.0 -> system slows down till reboot via
watchdog
    Qt with '-system-sqlite' and libsqlite 3.24.0 -> system slows down till reboot via
watchdog

Are there any known incompatibilites between Qt and libsqlite versions?

Or maybe compilte time flags that could should be added?

Any suggestions howto enclose the issue?

Thx for your time and interest.

Best regards
Thorsten

--
Thorsten Scherer | Eckelmann AG | www.eckelmann.de |
_______________________________________________
sqlite-users mailing list
[hidden email]
http://mailinglists.sqlite.org/cgi-bin/mailman/listinfo/sqlite-users
Reply | Threaded
Open this post in threaded view
|

Re: system reboot with Qt 4.8.7 and '-system-sqlite' using libsqlite >= 3.21.0

Richard Hipp-3
On 9/9/19, Scherer, Thorsten <[hidden email]> wrote:
>
> Are there any known incompatibilites between Qt and libsqlite versions?
>

I have not heard of any incompatibilities.  On the other hand, the
SQLite developers do not use Qt and we do not test against Qt, so this
is not something we track.  You might have better luck contacting the
Qt developers.
--
D. Richard Hipp
[hidden email]
_______________________________________________
sqlite-users mailing list
[hidden email]
http://mailinglists.sqlite.org/cgi-bin/mailman/listinfo/sqlite-users