uninstall help

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

uninstall help

Adi Spivak

hello.
i have sqlite 2.8.17 installed on my system (compiled manually not a distro
package)
i wish to remove it (uninstall) it complitlly from my system and install the
3.2.7
i need to make sure it is removed so i can make sure that the program i need
to install that will use sqlite will be compiled using sqlite3 libraries.
Thanks.
Adi Spivak

--
Oplag Internet Solutions. ( http://www.oplag.net )

Reply | Threaded
Open this post in threaded view
|

Re: uninstall help

Christian Smith
On Mon, 31 Oct 2005, Adi Spivak wrote:

>
>hello.
>i have sqlite 2.8.17 installed on my system (compiled manually not a distro
>package)
>i wish to remove it (uninstall) it complitlly from my system and install the
>3.2.7
>i need to make sure it is removed so i can make sure that the program i need
>to install that will use sqlite will be compiled using sqlite3 libraries.
>Thanks.


Well, SQLite 2.8.17 will be libsqlite, and SQLite 3.2.7 will be
libsqlite3. The two will co-exist, and you can't compile for one and run
on the other, they have different function prefixes. So, if you link with
-lsqlite3, you will be using 3.2.7 only.


>Adi Spivak
>
>--
>Oplag Internet Solutions. ( http://www.oplag.net )
>
>

--
    /"\
    \ /    ASCII RIBBON CAMPAIGN - AGAINST HTML MAIL
     X                           - AGAINST MS ATTACHMENTS
    / \